Sunday, October 30, 2011

Preparing another Gentoo KDE stable upgrade: KDE 4.7.2

With the blessing of the Gentoo KDE team, I have recently filed the request for stabilization of KDE 4.7.2, which means Gentoo stable users will see the upgrade sometime in the coming weeks, after the testing and the resulting bugfixing has completed.
In general the upgrade from 4.6.5 to 4.7.2 should be easy and bring quite some advantages; we're really happy with most of KDE 4.7.2 here. In particular also many quirks of the graphics acceleration have been ironed out.
However, there is one Big Thing happening with the upgrade: While the stable version of the KDE PIM applications (kontact, kmail, korganizer, ...) so far was still, we will try to stabilize KDE PIM 4.7.2 now. (Not my idea.) This is a major upgrade with potential for major breakage, especially since many people think that KDE PIM 4.7.2 has not even reached beta quality yet.
Why are we doing this, you may ask? Well, the big problem is, the upstream KDE PIM developers consider version obsolete and unsupported. The first regression has appeared (see Gentoo bug 382411 and KDE bug 279432), and we expect there will be more in the future. We will keep KDE PIM in Gentoo and try to support it as long as we can, but then we're not familiar with the code and cannot do too much on our own if things start to break.
Anyway. If you're brave and want to help us testing, please grab the list attached to the stable request, place it on your Gentoo system into /etc/portage/package.keywords, and upgrade your system.
  • If you want to upgrade the rest of KDE but not KDE PIM, grab the corresponding mask file and place it into /etc/portage/package.mask. This means all KDE PIM applications will remain at trusty version until you remove the mask entries again.
  • If you want to upgrade the entire KDE including KDE PIM to version 4.7.2, please read the KDE PIM upgrade guide in our new Wiki first. And yes, please feel free to contribute improvements there!
We're looking forward to hearing about your experiences, and if you encounter problems, please file bugs on our Gentoo bugzilla!


  1. It'd be nice if someone on the Kontact/KDE PIM team would do a status update on KMail2 so we all know what's going on there... I'm frankly quite scared for the next openSUSE release, which will ship 4.7.2...

  2. Definitely agree on the comment that Kmail 2 is not even beta. It unusable for day-to-day use for me. Nothing in the KDE commits even suggest that these problems are being worked on.

  3. Kmail2 is working well here on KDE 4.7.2 on OpenSUSE 11.4 from factory repository. Really. There are some minor issues but I cannot understand why it's called not even beta quality.

  4. I tried to use KMail for test purposes with googlemail and and a second imap email server and it was a bloody mess. Dead akonadi feeders, no responeses for minutes, sometimes the setup wizard didn't work at all and in the end I ran into the 'KMail encountered a fatal error and will terminate now. The error was: Failed to fetch the resource collection.' Error.

    Both on Gentoo and OpenSuSE 11.4

  5. I've tried KMail2 on Kubuntu and it worked well, so I started using it. Maybe it is a bit slow but it works. Haven't tried it on Gentoo yet.